View Issue Details

IDProjectCategoryView StatusLast Update
0004826OXID eShop (all versions)4.06. Language and translationspublic2013-09-19 11:33
Reportermarco_steinhaeuser 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.2 / 5.0.2 revision 53018 
Target VersionFixed in VersionPast development 
Summary0004826: As a shop administrator I want to enter more than three characters for language abbreviation (locale)
DescriptionIn admin -> languages it is not possible to enter a local (what we call an "abbreviation") with more than 3 characters. But very often, this is important: English, Spanish, French and even German have different dialects, orthography (e.g. color and colour) and may even have different words for the same thing. Also, you might want to have an informal version of the same language installed additionally (think of Russian => my | vy).

Please increase the number of possible characters at least to five so we can refer to this standard:
http://framework.zend.com/manual/1.12/en/zend.locale.appendix.html
Steps To Reproducetry to enter en_UK into the admin -> languages -> abbreviation
TagsLanguages
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

marco_steinhaeuser

2013-01-07 01:09

administrator   ~0008221

Last edited: 2013-01-07 01:15

View 2 revisions

Resolution:
/application/views/admin/tpl/language_main.tpl

Change maxlength="3" in [{ oxmultilang ident="LANGUAGE_ABBERVATION" }] into maxlength="10" or whatever you want but higher than "4". Or just delete it because it is not necessary ;)

ray

2013-01-07 01:15

reporter   ~0008222

even "255" would be ok and would not harm anyone - please change as well the longdescription to a higher value than 50

marco_steinhaeuser

2013-07-11 00:18

administrator   ~0008892

https://github.com/OXID-eSales/oxideshop_ce/commit/116b65f0a5ce7380104059b139a424ac618a7fac

martinwegele

2013-09-19 11:33

reporter   ~0009099

If you do not use the two-character language code from the ISO 639-1 specification for your languages the shop is no longer compatible with OXID eFire!