View Issue Details

IDProjectCategoryView StatusLast Update
0004811OXID eShop (all versions)2.9. Statisticspublic2013-01-02 10:57
ReporterWBL_BjoernLange 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.0 / 5.0.0 revision 51243 
Target Version4.7.3 / 5.0.3 revision 54408Fixed in Version4.7.3 / 5.0.3 revision 54408 
Summary0004811: Missing Include blocks rendering of statistics
DescriptionFatal error: Class 'Graph' not found in F:\xampp\htdocs\ep-trunk\www\application\controllers\admin\reports\report_conversion_rate.php on line 119

And i can see this in reports_base.php in the 4.7.2 SVN Tag:

/**
 * including libraries
 */
//require_once "$sIncPath/reports/jpgraph/jpgraph.php";
//require_once "$sIncPath/reports/jpgraph/jpgraph_bar.php";
//require_once "$sIncPath/reports/jpgraph/jpgraph_line.php";
//require_once "$sIncPath/reports/jpgraph/jpgraph_pie.php";
//require_once "$sIncPath/reports/jpgraph/jpgraph_pie3d.php";

And the autoloader can not find the class "Graph", because it is in the "jpgraph.php" and it searches a "graph.php".


TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Linas Kukulskis

2013-01-02 10:57

reporter   ~0008205

fixed include paths, updated autoloader