View Issue Details

IDProjectCategoryView StatusLast Update
0004785OXID eShop (all versions)1.11. Private Sales, Invitationspublic2021-03-19 10:54
Reporterhenrik.steffen 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformallOSallOS Versionall
Product Version4.7.1 / 5.0.1 revision 52468 
Target VersionFixed in Version 
Summary0004785: oxstock is increased after expiry of reservation
DescriptionIf a product is set to oxstockflag = standard and oxstock = 0 it can usually be ordered (or pre-ordered) in oxid eshop.


If "private sales" is activated, a reservation will be made to the product by descreasing the oxstock amount by 1.

If the oxstock amount, as in this case, is already 0 and setting "allow negative stock amounts" is disabled, the oxstock amount will not be decreased, it remains on 0 instead.

Now, if the basket expires, the oxstock is set to 1.... which is 1 more than there has originally been.

Steps To ReproduceSet a product to oxstock = 0 and oxstockflag = standard

Activate Private Sales

Make sure negative stock amounts are disabled

Put product with oxstock = 0 into basket

Wait until basket expires

See stock amount in admin, and find it on oxstock = 1

TagsStock
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

related to 0007220 closed 0-inventory product increased after order declined/canceled 

Activities

jurate.baseviciene

2012-12-10 13:31

reporter   ~0008080

Reminder sent to: henrik.steffen

Hi,

Sorry, but we cannot reproduce the issue on 5.0.1 versions eShop. Let's make it clear that we do everything the same way:

1. We set a product (1402) to oxstock = 0 and Delivery Status = standard;
2. "Private Sales Login" is Enable
3. Allow negative Stock Values - is off
4. Need to put product (1402) with oxstock = 0 into basket
5. Then Wait until basket expires
6. And then see stock amount in admin, and find it on oxstock = 0, oxstock is not set to 1

Could you please try to reproduce that on our demo shops:
 http://demoshop.oxid-esales.com/community-edition/ ? Maybe some other special options are turned on?

henrik.steffen

2013-01-02 08:10

reporter   ~0008201

Indeed, I can't reproduce it now in 4.7.1 - I tested in 4.5.9. Seems like it has been fixed.

jurate.baseviciene

2013-01-02 08:26

reporter   ~0008204

Hi,

Unfortunately we can't reproduce such issue nor on 4.6. neither on 5.0.0 versions. Probably is fixed with other change. If in the future this bug will be reproduced please bug status change to "Reopen". And please written for more details how bug need reproduce.

Best regards,