View Issue Details

IDProjectCategoryView StatusLast Update
0004686OXID eShop (all versions)2. ----- eShop backend (admin) -----public2012-11-08 15:20
ReporterWBL_BjoernLange 
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.0 / 5.0.0 revision 51243 
Target VersionFixed in Version4.8.0_5.1.0_beta1 
Summary0004686: oxconfig.oxvarname too short
DescriptionSince the module config can be managed with the module backend and the database, namespacing became even more important, even with the config vars. But char(32) could be too short, for good namespaced config varnames.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

vaidas.matulevicius

2012-11-08 15:20

reporter   ~0007777

This fields and related fields (OXCFGVARNAME from oxconfigdisplay table) size will be doubled.
If you want to change it for your current database please use this SQL script:
ALTER TABLE oxconfig MODIFY `OXVARNAME` CHAR(128) COLLATE latin1_general_ci;
ALTER TABLE oxconfigdisplay MODIFY `OXCFGVARNAME` CHAR(128) COLLATE latin1_general_ci;