View Issue Details

IDProjectCategoryView StatusLast Update
0004643OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2014-03-04 11:24
Reportermartinwegele 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.7.0_5.0.0_RC1 
Target VersionFixed in Version 
Summary0004643: some discounts do not display in the basket
DescriptionI am unsure if this is a bug or an intented feature. This is a really strange behaviour but easily reproduced:
Steps To ReproduceIn our demoshop http://demoshop.oxid-esales.com/enterprise-edition/ put product Kite Core GTS (article number 1208, price 879 EUR) into the basket. Then go to basket overview and see that the grand total price is 791,10 EUR because of discount "Aktion Schn├Ąppchen" (="Current bargain") which gives 10% discount for the whole category kites. (default demo data setting)
Now go try the same in the http://demoshop.oxid-esales.com/beta/professional-edition/ (put kite core gts in basket and display cart). The discount is applied directly to the item and not displayed above the grand total.
TagsBasket, Discount
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

dainius.bigelis

2012-10-19 07:57

reporter   ~0007639

Since version 4.7.0/5.0.0 such discouns, which are applicable for product (or related category) - will be shown in product line. There you will see the original price crossed and active price is already with included discount. This is much more clear which discount is applicable for what particular products, and then the Total amounts looks more correctly (as this discount is always counted from product price, not from Total amounts).
Previously, when such discounts for product were shown in Total amount group (but still counted from product price), it looked that discounts are calculated incorrectly, when it was just simply places in incorrect place (should be per line, not in total group).

martinwegele

2012-10-23 16:39

reporter   ~0007654

I see. This is an improvement.
However it would be more transparent for the customer if the name/title of the discount would be displayed nearby.
In this special case there was also a recommended retail price (RRP) entered for the product which is displayed as a striked price on the detail page. Now in the basket/cart the item's striked price is different. This might confuse the customer, esp. if there is no reason (= name/title of the discount) displayed for the new (lower) price.

Linas Kukulskis

2012-12-18 12:48

reporter   ~0008158

from 4.7/50 this kind of price calculation was introduced