View Issue Details

IDProjectCategoryView StatusLast Update
0004607OXID eShop (all versions)2.3. Extensions (modules, themes)public2012-12-10 13:33
ReporterGueltekin_Koc 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.0_5.0.0_RC1 
Target Version4.7.0_5.0.0_RC2Fixed in Version4.7.0_5.0.0_RC2 
Summary0004607: Cannot create custom theme in 5.0.0 version
DescriptionNot possible to create customized theme!

1-) I just have created a new theme custom and when activated it on the backend
 
 copy azure theme as custom in out/ and application/views/
 change the “id” and “title” to custom in the theme.php (in custom directory )

2-) go to the frontend, you will get the following error on the HOME page:

Warning: Smarty error: unable to read resource: "widget/product/listitem_.tpl" in /var/www/tekinsshops/ee500RC1/core/smarty/Smarty.class.php on line 1093 Call Stack: 0.0005 321808 1. {main}() /var/www/tekinsshops/ee500RC1/oxseo.php:0 0.0008 324144 2. require('/var/www/tekinsshops/ee500RC1/index.php') /var/www/tekinsshops/ee500RC1/oxseo.php:38 0.0089 501816 3. Oxid::run() /var/www/tekinsshops/ee500RC1/index.php:20 0.0238 892748 4. oxShopControl->start() /var/www/tekinsshops/ee500RC1/core/oxid.php:32 0.1040 6243080 5. oxShopControl->_process() /var/www/tekinsshops/ee500RC1/core/oxshopcontrol.php:115 0.3423 11544676 6. oxShopControl->_render() /var/www/tekinsshops/ee500RC1/core/oxshopcontrol.php:387 0.3854 12330396 7. Smarty->fetch() /var/www/tekinsshops/ee500RC1/core/oxshopcontrol.php:588 0.3861 12425988 8. include('/var/www/tekinsshops/ee500RC1/tmp/smarty/c7167f3ffa9d127d0480ca6733482a44^%%40^405^405277AF%%start.tpl.php') /var/www/tekinsshops/ee500RC1/core/smarty/Smarty.class.php:1263 0.5889 15723756 9. Smarty->_smarty_include() /var/www/tekinsshops/ee500RC1/tmp/smarty/c7167f3ffa9d127d0480ca6733482a44^%%40^405^405277AF%%start.tpl.php:60 0.5896 15766508 10. include('/var/www/tekinsshops/ee500RC1/tmp/smarty/c7167f3ffa9d127d0480ca6733482a44^%%FC^FCA^FCA347E9%%list.tpl.php') /var/www/tekinsshops/ee500RC1/core/smarty/Smarty.class.php:1869 0.5902 15768644 11. Smarty->_smarty_include() /var/www/tekinsshops/ee500RC1/tmp/smarty/c7167f3ffa9d127d0480ca6733482a44^%%FC^FCA^FCA347E9%%list.tpl.php:44 0.5902 15771204 12. Smarty->_compile_resource() /var/www/tekinsshops/ee500RC1/core/smarty/Smarty.class.php:1867 0.5902 15771444 13. Smarty->_fetch_resource_info() /var/www/tekinsshops/ee500RC1/core/smarty/Smarty.class.php:1415 0.5908 15772776 14. Smarty->trigger_error() /var/www/tekinsshops/ee500RC1/core/smarty/Smarty.class.php:1589 0.5908 15773004 15. trigger_error() /var/www/tekinsshops/ee500RC1/core/smarty/Smarty.class.php:1093
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005127 resolvedtomas.lygutas New theme should not crash if some options are missing 

Activities

vilma_liorensaityte

2012-10-12 10:33

administrator   ~0007598

Last edited: 2012-10-12 10:35

View 2 revisions

The problem is, that you are using custom theme options in your templates, but forgot to add them into database.
For this case, I added a default list display type "infogrid" in widgets/product/list.tpl and it will not show this warning message anymore in start page. But for future, keep in mind to add custom theme option.