View Issue Details

IDProjectCategoryView StatusLast Update
0004586OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
Reporteralfonsas_cirtautas 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.0_5.0.0_beta3 
Target VersionFixed in Version4.7.0_5.0.0_RC1 
Summary0004586: Custom module templates registered in module metadata are rendered as blank with php 5.4
DescriptionCustom module template injection is implemented using Smarty 2 default template callback function. When this function is called, templates are located correctly, but their content is not returned, this results empty page.
Additional Informationsee oxUtilsObject::_smartyDefaultTemplateHandler()
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Version5.4
MySQL Versionany

Relationships

duplicate of 0004138 resolvedjurate.baseviciene _smartyDefaultTemplateHandler (oxutilsview) ist not compatible with PHP 5.4.x 

Activities

alfonsas_cirtautas

2012-10-03 13:50

reporter   ~0007538

Workaround: move templates to shop template dir

alfonsas_cirtautas

2012-10-04 10:18

reporter   ~0007551

Upgrading to smarty 3 would be best solution for this issue

leofonic

2012-10-04 14:23

reporter   ~0007553

duplicate of 0004138 i think

alfonsas_cirtautas

2012-10-05 02:43

reporter   ~0007559

Variable passing by reference fixed as suggested in 0004138 , it is good temporary solution, before upgrading to smarty 3