View Issue Details

IDProjectCategoryView StatusLast Update
0004548module PayPalmodule PayPal - subpublic2014-12-15 15:00
Reportermichael_keiluweit 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.0.2 
Target Version4.0.0Fixed in Version 
Summary0004548: if there are some order information changes, the PayPal module sets the order status to NOT_FINISHED
Descriptionif there are some order information changes, the PayPal module sets order status to NOT_FINISHED.
Steps To Reproduce1. Order something and pay with express checkout or normal PayPal payment.
2. Payment is correctly and you can see in the administration area the payment date
3. Internal status of the order is "OK".
4. Change the order information like invoice number (see attachment) and save it. After that, the internal status is "NOT_FINISHED"

If you try this with the PayPal module deactivated, it works correctly. The internal status wouldn't be changed.
Additional InformationEE 4.6.2
PayPal 2.0.2
TagsOrder

Relationships

related to 0004624 acknowledged OXID eShop (all versions) Order recalculation does not use discounts/taxes which were valid when order was made, but current ones 

Activities

michael_keiluweit

2012-09-24 09:14

developer  

invoice__number.PNG (57,773 bytes)
invoice__number.PNG (57,773 bytes)

michael_keiluweit

2012-09-24 09:18

developer   ~0007474

Is there a way to make a quick fix?

dainius.bigelis

2012-10-18 17:18

reporter   ~0007634

Actually this is the issue of eShop. But it's occurs only in additioanl payment methods, which overrides/extends the eShop order class.
The issue is, that recalculateOrder method is called always, when any detail is changed in existing Order in admin, no matter what detail is changed.
It is ok, when detail is related to the changes in prices or Total money amounts and order really should be recalculated.
But there are some fields, which are just kind of additional information for order, like Invoice no. If such details are changed, recalculateOrder method should not be called.
So fix would be - to select the fields, which are not related to the prices/totals in order and do not call this method (better say - call it when it's really needed).

P.s.:
the issue occurs in PayPal only, because when recalculateOrder is called in usual case, it recalculates the order and sets the OK status again. PayPal in this case set's the status "NOT FINISHED", but, as we assume the Total amounts are changed in this case, it is left as NOT FINISHED, to take attention from shop owner (in ths case money amount charged in PayPal, and recalculated order might not match, so need to be handled manually).

dainius.bigelis

2012-10-18 17:19

reporter   ~0007635

P.s.: changed here have some significant risk for handling order in Admin. So we planning to spend more time on that and fix that later with next Patches of eShop.

jurate.baseviciene

2014-12-15 15:00

reporter   ~0010458

Hi,

Bug is closed, because we cant reproduce this behavior 'from PayPal version 3.0.0,
This bug is able to reproduce only on older PayPal versions.
Best regards,
Jurate