View Issue Details

IDProjectCategoryView StatusLast Update
0004547OXID eShop (all versions)1. ----- eShop frontend -----public2012-12-10 14:37
Reporterray 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.0_5.0.0_beta2 
Target VersionFixed in Version4.7.0_5.0.0_RC2 
Summary0004547: missing label for "to basket"-link in order history
DescriptionThe code is commented in ../page/acount/order.tpl line 79 due to TS precertification. But anyway, if someone uncomments it will not work, as a label or button for the link is missing - it will not show up in frontend.

Please include a language variable (maybe 'ADD_TO_CART') or a button.
Steps To Reproduce[{* Commented due to Trusted Shops precertification. Enable if needed *}]
  [{*
  [{oxhasrights ident="TOBASKET"}]
   [{if $oArticle->isBuyable() }]
    [{if $oArticle->oxarticles__oxid->value }]
     <a id="accOrderToBasket_[{$order->oxorder__oxordernr->value}]_[{$smarty.foreach.testOrderItem.iteration}]" href="[{ oxgetseourl ident=$oViewConf->getSelfLink()|cat:"cl=account_order" params="fnc=tobasket&aid=`$oArticle->oxarticles__oxid->value`&am=1" }]" rel="nofollow">MISSING LABEL</a>
    [{/if }]
   [{/if }]
  [{/oxhasrights}]
  *}]
Additional Informationsame thing in Basic in 4.6.x of course
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

vilma_liorensaityte

2012-10-11 14:22

administrator   ~0007590

just added a language constant.