View Issue Details

IDProjectCategoryView StatusLast Update
0004529OXID eShop (all versions)1. ----- eShop frontend -----public2012-12-10 14:37
Reporteravenger 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.4 revision 49061 
Target VersionFixed in Version4.7.2 / 5.0.2 revision 53018 
Summary0004529: Declaring call methods as "private" prevents easy subclassing....
DescriptionI need to suclass the "getClassName( $sClassName )" of oxutilsobject, which is a problem, as the call to "$this->_makeSafeModuleClassParents( $aClassChain, $sParent );" throws an error, because "makeSafeModuleClassParents" is defined as private....

So only to resolve this probleme, you must copy "makeSafeModuleClassParents" also to your subclass module....

Use the "protected" keyword instead.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Linas Kukulskis

2012-11-27 16:58

reporter   ~0008000

changed