View Issue Details

IDProjectCategoryView StatusLast Update
0004444OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2013-01-09 14:02
Reporterjurate.baseviciene 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.3 revision 47975 
Target Version4.7.0_5.0.0_beta3Fixed in Version4.7.0 / 5.0.0 revision 51243 
Summary0004444: if you try to choose a product variant in eshop then you are redirect to home page,
DescriptionIn frontend does not work products with variants.

Open shops start page,
Search a product 3570.
Select variant W30/L30.
Then you are redirect to the start page.
TagsProducts
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

tomas_liubinas

2012-08-23 16:18

reporter   ~0007383

Reproduced. This happens when SEO URLs are off only. (in config.inc.php set $this->blSeoMode = false;)

dainius.bigelis

2012-10-01 10:56

reporter   ~0007513

The fix needs template changes, so changed target version to "5.0.0"

tomas_liubinas

2012-10-01 11:05

reporter   ~0007514

Basically the reason causing the problem is that POST request ignores parameters provided in <form> action attribute. Therefor the parameters like cl=details&anid=productId (which are specified in action attribute when search engin urls are of) are ignored and it does not know it should lead to details page, therefore it lands to the default start page.

saulius.stasiukaitis

2012-10-02 13:44

reporter   ~0007526

There were no cl parameter and anid parameter in form, that's why it only worked with SEO link. Those parameters were added in to files listitem_grid.tpl and listitem_infogrid.tpl
    <input type="hidden" name="cl" value="details">
    <input type="hidden" name="anid" value="[{ $product->oxarticles__oxnid->value }]">