View Issue Details

IDProjectCategoryView StatusLast Update
0004428module PayPalmodule PayPal - subpublic2012-08-23 13:34
Reportersvetlana 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.2 
Target Version2.0.2Fixed in Version2.0.2 
Summary0004428: For not log in user shipping cost rules calculation works incorrect
Description1. Paypal payment method is assigned to Germany
2. Shipping methods( Standard; Example Set1: UPS 48 hours; Example Set2: UPS Express 24 hours->is assigned to Germany.
3.Shipping cost rules:
  - Shipping costs for Example Set2: UPS 24 hrs Express: $12.90->is assigned to Germany.
  - Shipping costs for Example Set1: UPS 48 hrs: $9.90 ->is assigned to Germany.
  - Shipping costs for Standard: Free shipping over 500->is assigned to Germany.
  - Shipping costs for Standard: $3.90 from 0 to 80 ->is assigned to Germany.
  - Shipping costs for Standard: $6.90 from 80 to 500 ->is assigned to Austria.

4. Not login user added a product for 130 Eur.
5. Purchase via Express PayPal as Germany user.
6. In PayPal should be 2 shipping methods: "Example Set1: UPS 48 hours" and "Example Set2: UPS Express 24 hors", but are 3. Standard also is included with incorrect price 9.90. Standard should not appear because it don't match rules
TagsNo tags attached.

Activities

rimvydas_paskevicius

2012-08-23 13:34

reporter   ~0007371

Updated checking which delivery methods fits to current user and basket.