View Issue Details

IDProjectCategoryView StatusLast Update
0004426OXID eShop (all versions)2.4. Administer productspublic2014-05-30 10:58
Reporterdesign3000 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.9 revision 43186 
Target Version4.6.6 revision 54646Fixed in Version4.6.6 revision 54646 
Summary0004426: Generic import: OXID = ArtNum
DescriptionWhen importing via generic csv import in admin area, the imported product's article number is written into the db-field OXID.

In our case this sometimes leads to problems when those products are exported to our ERP software (pixi*), because the ArtNum (and thus, the OXID) might be shorter than 13 characters. Pixi then changes e.g. the ID "Originalnr" to "000Originalnr" so it has 13 character. As a result, the connection Oxid <-> Pixi is lost and so stock changes won't be transmitted correctly.

I know this is a problem that exists mainly when using Pixi, but nevertheless the ArtNum is per se not unique so there might be other problems caused by this behavior. (I did not try to import 2 products with the same ArtNum yet).

IMHO the generic import should generate a nice 32 characters OXID.
Steps To Reproduce1.) Import some product via generic import module in oxid admin using "example" als ArtNum
2.) Have a look at the product in the database: the OXID of the product is "example"
TagsImport, Products
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

aurimas.gladutis

2012-12-18 16:36

reporter   ~0008175

Changed so that if no oxid field is specified, oxid is generated.

martinwegele

2014-05-30 10:58

reporter   ~0009932

https://github.com/OXID-eSales/oxideshop_ce/blob/v4.6.7/source/core/oxerpcsv.php#L422