View Issue Details

IDProjectCategoryView StatusLast Update
0004381OXID eShop (all versions)2.3. Extensions (modules, themes)public2012-12-10 13:33
Reporterleofonic 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.0_5.0.0_beta1 
Target VersionFixed in Version4.7.0_5.0.0_beta2 
Summary0004381: Module activation/deactivation does not work
DescriptionModule activation/deactivation does not work
Additional Information/tmp/amodules.txt, amodulepaths.txt, adisabledmodules.txt are not updated on module activation/deactivation.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

arturas.sevcenko

2012-08-17 14:52

reporter   ~0007336

Last edited: 2012-08-20 12:48

View 3 revisions

Module activation/deactivation works correctly if modules are placed in their own folders. Modules of one standalone file without folder can't be deactivated, but eShop shows a warning for that if it detects standalone file in modules dir.

leofonic

2012-08-17 16:29

reporter   ~0007337

Why has your Note disappeared?

Reproduce Testscript:

<?php
include "bootstrap.php";
$oOrder = oxnew ('oxorder');
echo get_class($oOrder);

shows "Myorder" on a fresh install. Deactivate Module "Invoice PDF", still shows "Myorder". Clear tmp, it shows "oxorder". Same on activation.

arturas.sevcenko

2012-08-20 09:17

reporter   ~0007339

Last edited: 2012-08-20 12:48

View 4 revisions

In current development version there is no issue for your testscript.

FibreFoX

2012-08-21 18:09

reporter   ~0007352

Last edited: 2012-08-21 18:46

View 3 revisions

i think its related to this bug-entry:

(im using 4.6.3 CE)

steps to reproduce:
 - create a simple module
 - install it
 - activate it
 - deactivate it
 - rename that folder (e.G. prefixing with an underscore -> "mymodule" becomes "_mymodule")
 - click in admin on "extension>modules"
 - re-rename that module-folder (in the filesystem)
 - config-data "aModulePaths" still is containing "_mymodule" !!!!
 
i dont know how to reset that paths without deep hacking, maybe there should be additional is_existing-checks

also if "_mymodule" AND "mymodule" are existing both AFTER that steps, the metadata from "mymodule" is loaded, but the path still is wrong and the shop complains about "this is a single file module"

FibreFoX

2012-08-22 00:35

reporter   ~0007353

maybe this helps: i created a fix for my problem, i hope it helps for this bug too (maybe its the same)

http://forum.oxid-esales.com/showthread.php?p=99254#post99254
http://www.dynamicfiles.de/download.me/oxid/module_path_fix.zip

arturas.sevcenko

2012-08-24 10:15

reporter   ~0007386

Small handling issues fixed