View Issue Details

IDProjectCategoryView StatusLast Update
0004320OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2015-05-04 14:42
ReporterOxidUser 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0004320: Shop makes no differences between gross amounts and net figures when using coupons.
DescriptionWe are having problems right now with handling vouchers for a shop that ships to almost any country worldwide.
Since many of those countries are supplied outside the EU, there are quite a few users who can order without VAT.
So there are both orders with gross amounts, and orders with net figures.
In this context, we have now had a look at the voucher handling and noticed that Oxid apparently makes no difference whether it is a gross or net order.
To illustrate: There is a coupon code for a coupon for 10 EUR. If a customer from Germany is using this coupon, the gross amount of the order will be reduced by 10 EUR.
If a customer from the USA is using this coupon, the net amount of the order will be reduced by 10 EUR.
The coupon then is of different worth , depending on who redeems him.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Linas Kukulskis

2012-11-14 14:17

reporter   ~0007853

to apply reduction of VAT amount to voucher its strange ;)
better way is manage your vouchers in right way:
for customers you can get 0% VAT crate separate vouchers , assign users group which include them.