View Issue Details

IDProjectCategoryView StatusLast Update
0004317OXID eShop (all versions)1.11. Private Sales, Invitationspublic2016-02-12 09:54
ReporterLG 
PrioritynormalSeveritycriticalReproducibilityalways
Status closedResolutionduplicate 
Product Version4.4.0 revision 28699 
Target VersionFixed in Version 
Summary0004317: OXID private sales is not compatable with the high attendance shops
DescriptionOXID private sales is not compatable with the high attendance shops. When the stream of visitors is high, OXID discards the expired sales (after cart expires) and renews the stock listing incorrectly (race condition!). For example instead of the remaining stock of 10 items – OXID can renew it into 15.

The problem is with oxarticles::reduceStock - no transaction is used to ensure correct stock management during heavy load.
Additional InformationProject uses OXID PE 4.4 but oxarticles::reduceStock is same as in 4.6.3
TagsHigh_Load, Stock
ThemeNot defined
BrowserAll
PHP VersionNot defined
Database Version5.1

Relationships

duplicate of 0006102 resolvedHR Article Stock Function causes wrong stock levels in high load scenarios / Use transactions 

Activities

vschmi

2016-01-27 16:11

reporter   ~0011446

This seems to be exactly the same issue as 0006102. Can be any progress expected in the near future?

QA

2016-02-12 09:53

administrator   ~0011466

Closed this entry as duplicate, because 0006102 is more detailed.