View Issue Details

IDProjectCategoryView StatusLast Update
0004278OXID eShop (all versions)1. ----- eShop frontend -----public2012-12-10 14:37
ReporterFibreFoX 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.2 revision 46646 
Target VersionFixed in Version4.7.1 / 5.0.1 revision 52468 
Summary0004278: unneeded assignments in oxutils
Descriptionthe following methods seem to have unneeded assignments (may improve some performance due to unneeded value-copying:


    public function getCacheFilePath( $sCacheName, $blPathOnly = false, $sExtension = 'txt' )
    {
        $sVersionPrefix = "";


            $sVersionPrefix = 'pe';

        -> unneeded code/assignment
    
    
    public function loadAdminProfile($aInterfaceProfiles)
    {
        // improved #533
        // checking for available profiles list
        $aInterfaceProfiles = $aInterfaceProfiles;

        -> unneeded code/assignment
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Linas Kukulskis

2012-11-15 17:19

reporter   ~0007871

fixed