View Issue Details

IDProjectCategoryView StatusLast Update
0004274OXID eShop (all versions)1.03. Basket, checkout processpublic2012-11-14 14:17
ReporterFirefax 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.2 revision 46646 
Target VersionFixed in Version4.6.6 revision 54646 
Summary0004274: Discount item ITM (Rabatte) produces massiv Pop-Up Info while Checkout (when activ)
DescriptionTheme Azure and "Open Popup" is selected as feature, when product is added to cart.
Now you make a discount with an item. The item will be put to basket, when e.g. the basket reaches 50€.

Problem:
When you go to the basket, the pop-up appers that an item is put to the basket. This might be accaptable, but i think it is not needed. This is no "regular" / paid item.
The next "wrong" pop-up is comming in Step 3 (Payment Method). There are no new items in the basket. The only way to close this pop-up is to press the small x-icon.

In step 4 the same pop-up comes. Again no new items in the basket and the only way to close the pop-up is the small x.

The customer will be trapped in this loop. He reaches step 3 or 4 and the buttons will bring him to back to step 1 or 2. Noone will finish the checkout.

There should be NO pop-ups inside the check-out.
Steps To ReproduceTheme Azure and "Open Popup" is selected as feature, when product is added to cart.
Now you make a discount with an item. The item will be put to basket, when e.g. the basket reaches 50€.

Go to the Checkout and see all the upcoming Pop-Ups.
Additional InformationGerman Description: http://forum.oxid-esales.com/showthread.php?p=96310#post96310
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Firefax

2012-07-21 16:11

reporter   ~0007116

The customer will be trapped in a "pop-up loop", when he reaches the check-out step 1, 3 or 4 the popup will bring him back to Step 1 or 2. The only way to get out of the loop is to press the small x-button.

I think there should be no Pop-Ups inside the basket.

ray

2012-07-22 00:38

reporter   ~0007120

workaround in forums:
http://forum.oxid-esales.com/showthread.php?t=15427#post96326

Firefax

2012-07-23 14:36

reporter   ~0007124

Hi,
the features of the pop-up, when you put an item in the basket also differs in the Azure and Basic Version. The Features and buttons are different, e.g. in Azure, there is no button to "Continue Shopping" ...

I changed to the "Show Message" again and made the messeage more highlighted to my customers, because the pop-up can not be used in the azure template.