View Issue Details

IDProjectCategoryView StatusLast Update
0004257OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2012-12-07 14:23
ReporterMitmacher 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version4.6.2 revision 46646 
Target VersionFixed in Version 
Summary0004257: Redirecting to home if you try to rate/review a recommlist (listmania) with Javascript disabled
DescriptionIt seems to be there is missing some code to allow a none-javascript fallback for rating/reviewing recommlists (listmania) the same way it is implemented for product reviews. I looked into the code and found many lines which distinguishes between recommlist and product reviews (so this functionallity is definiately wanted) but alltogether it doesn't work.

This kind of links will always redirect you to home:
http://demoshop.oxid-esales.com/community-edition/bewertungen/?recommid=qo8cd7e23f455f77686afdde46482149&listtype=recommlist&ldtype=infogrid
Steps To Reproduce- disable javascript
- login into demo shop (basic theme)
- create a recommendation list
- add a product to this recommlist
- open the recommlist page
- use the link "Write review" (Kommentar schreiben)
- you will be redirected to home
TagsRatings, Reviews
ThemeBasic
BrowserAll
PHP Versionany
Database Versionany

Relationships

related to 0002916 resolvedjurate.baseviciene Basic Theme: "more info" Button missing when "load variants in lists" is deactivated 

Activities

jurate.baseviciene

2012-08-08 12:07

reporter   ~0007264

Hi,

Thanks a lot for submitting this issue, but we cant resolve this issue, because we supports only Azure theme. Basic theme in new version is not supported. Furthermore, the issue needs template changes.

Greetings,

Mitmacher

2012-08-16 23:12

reporter   ~0007332

Okay, but this issue also affects the azure them as I noticed today! :-(
And I am not sure if it "needs template changes", the bug seems to be placed in the core logic. So please check it again and give us a fix if possible.
It is not much important to me that it works without javascript, but I want to use this functionality in a different way (maybe I am not alone)...

jurate.baseviciene

2012-11-13 15:22

reporter   ~0007843

Hi,

 For azure theme there is a requirement, that javascript should be enabled. Otherwise lot of the stuff will be not working in this theme, and to fix that properly (to have static pages working with all functionality) would need enourmous amount of time. So we will not fix that.