View Issue Details

IDProjectCategoryView StatusLast Update
0004256OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2012-12-07 14:27
Reportermichael_keiluweit 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.2 revision 46646 
Target VersionFixed in Version4.8.0_5.1.0_beta1 
Summary0004256: after choosing size of a variant article the picture doesn't change after choosing the color anymore
DescriptionOXID demoshop - article is the t-shirt. If you click on the product and choose the colour grey, the picture of the article will change accordingly. If you choose the size first and then the colour, the picture will always display the shirt in colour red.
Steps To ReproduceOpen Demoshop
Click on t-shirt
choose colour grey.
=> picture will change to grey
Repeat:
open demoshop
click on t-shirt
choose any size
choose colour grey
=> picture will remain red
TagsProducts
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

leofonic

2012-11-28 20:55

reporter   ~0008021

I think there are just no images for grey M and L in Demodata.

aurimas.gladutis

2012-11-29 09:43

reporter   ~0008023

Hi, yes, there were no images for those variants, so parent article pictures were shown. Pictures were added (will be added to demoshop also after release) so it would not cause more confusion.

michael_keiluweit

2012-11-30 09:42

developer   ~0008029

I can still reproduce it on our 4.7.1 demoshop: http://demoshop.oxid-esales.com/professional-edition/Bekleidung/Fashion/Fuer-Ihn/Shirts-Co/Kuyichi-T-Shirt-TIGER.html

Change first the size and then change the color to grey. You will see the orange t-shirt as picture.

Refresh the page and change first the color and then the size. Now it works as it should.

leofonic

2012-11-30 09:52

reporter   ~0008030

Michael if i choose M/grey picture is always orange no matter what i select first.

aurimas.gladutis

2012-11-30 10:30

reporter   ~0008032

Last edited: 2012-11-30 10:41

View 2 revisions

will be released in 5.1 as there are demodata changes and addition of pictures, so please be patient. The problem is minor and only in demodata as there were and still is no images uploaded to those variants. If you really need the fix, please add missing pictures to that article variants and it will be fine.

michael_keiluweit

2012-11-30 10:38

developer   ~0008033

Hi Aurimas,

sorry I didn't saw "(will be added to demoshop also after release)". Got it now :)