View Issue Details

IDProjectCategoryView StatusLast Update
0004255OXID eShop (all versions)2.3. Extensions (modules, themes)public2012-12-10 13:33
ReporterMitmacher 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.2 revision 46646 
Target VersionFixed in Version4.6.4 revision 49061 
Summary0004255: Typo in settings parameter "constrains" which can be used in metadata.php for select lists
DescriptionOXID uses the "constraints" parameter for building select lists for config vars and since 4.6.0 it is possible to use this also for individual module settings within metadata.php. Unfortunately there is a typo (missing second "t") which could lead to some confusions.
So I decided to set priority to urgent because if the typo will be corrected (not really sure if neccessary or useful) than it should be done as soon as possible! But be careful:
There may be already some modules published which uses "constrains" (wrong) so it may be the best to check for both variants to keep module compatibility.
Steps To ReproduceNope.
Additional InformationMy suggestion is replacing line 778:
$sConstrains = $aValue["constrains"]?$aValue["constrains"]:'';

by:
$sConstraints = '';
if ( $aValue["constraints"] )
    $sConstraints = $aValue["constraints"];
elseif ( $aValue["constrains"] )
    $sConstraints = $aValue["constrains"];

and setting the db insert value accordingly (8 lines below):
".$oDb->quote($sConstraints)."
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

arturas.sevcenko

2012-07-31 15:33

reporter   ~0007166

Suggestion reviewed. Fixed.