View Issue Details

IDProjectCategoryView StatusLast Update
0004254OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2013-11-14 17:11
ReporterMitmacher 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.2 revision 46646 
Target Version4.7.10 / 5.0.10Fixed in Version4.7.10 / 5.0.10 
Summary0004254: Faulty checking of valid $dRating in function saveReview() within class recommlist.php
DescriptionSince OXID 4.6.0 a small bug has been corrected in details.php but the same logic also exists in recommlist.php where it has not been fixed. Please fetch it later. It is as simple as replacing "0" with a "1", so replace line 200:

if ( $dRating !== null && $dRating >= 0 && $dRating <= 5 ) {

with this one:

if ( $dRating !== null && $dRating >= 1 && $dRating <= 5 ) {
Steps To ReproduceLook at the function code... ;-)
TagsRatings, Reviews
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Mitmacher

2013-11-13 22:36

reporter   ~0009267

Sorry, I really don't know, if I had to open a new report for this!?
But for some reason I forgot to mention that this kind of error also exists in another class since OXID 4.5 until now (4.8.0):

Please correct the line 197 in application/controllers/review.php in the same way because it makes less sense to store oxratings with no real rating value. Thanks!

Linas Kukulskis

2013-11-14 17:11

reporter   ~0009270

changed to 1