View Issue Details

IDProjectCategoryView StatusLast Update
0004224OXID eShop (all versions)3.1. Design, GUI, UXpublic2012-11-15 17:11
Reporterdesign3000 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.2 revision 46646 
Target VersionFixed in Version4.8.0_5.1.0_beta1 
Summary0004224: Changing E-Mail Address fails without error message if user enters wrong password
DescriptionWhen a user wants to change his e-mail-address in "my account", the password field appears. If the user then enters a wrong password, the form is submitted but the e-mail-address is not changed. There is no feedback that somathing went wrong until the user clicks on "change" again. When he does so, a wrong error message appears ('Passwords don't match!').

IMHO there is no need to ask the users password here, because he is already logged in. Maybe a confirmation e-mail should be sent to the new e-mail-address.
Steps To Reproduce1.) In demo shop, create a new user
2.) In "My Account > Billing and Shipping Settings > Billing Address" click "change"
3.) Change E-Mail-Address
    > The password field appears
4.) Type in wrong password
5.) Click "save"
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

leofonic

2012-10-31 20:57

reporter   ~0007696

Also the label should read "Please enter your current password to confirm email address change" or something like this, because the label "Password" suggests that you could enter a new Password, just like you can enter changed data in all the other fields.

Imho "Billing Address" is the wrong place for e-mail address change, a better place could be "Account Settings", where customer could choose email change, password change and newsletter settings.

aurimas.gladutis

2012-11-15 17:11

reporter   ~0007870

Thank you for your suggestions on changing the interface, we will consider it.

As for the password, it was checked, but the form with error was not showing up after submit. This will be fixed in the 5.1 patch. If you need to fix it in earlier versions, just update tpl/form/user.tpl 19 line to:
<ul class="form clear" [{if empty($aErrors)}]style="display: none;"[{/if}] id="addressForm">
   [{ include file="form/fieldset/user_email.tpl" }]
   [{ include file="form/fieldset/user_billing.tpl" noFormSubmit=true }]