View Issue Details

IDProjectCategoryView StatusLast Update
0004223OXID eShop (all versions)3.1. Design, GUI, UXpublic2013-06-18 15:29
Reporterdesign3000 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.2 revision 46646 
Target VersionFixed in Version4.8.0_5.1.0_beta1 
Summary0004223: Problem with input validation street/no. & zip/city
DescriptionThe jquery input validation for the address form seems to check "double" input fields (e. g. a combination of two input fields like Street and streetno.) at once . As the input validation event occurs "onblur" of the first input field, the second input field would be empty yet and thus lead to the "not empty" error message (s. screen attached). This might be quite irritating for users because he gets an error message without having done anything wrong ;)
Steps To ReproduceSimply fill in the address form
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

design3000

2012-07-06 14:23

reporter  

aurimas.gladutis

2013-06-18 15:29

reporter   ~0008782

Last edited: 2013-06-18 15:37

View 2 revisions

The fix was added to 5.1 version, as it does require javascript widget change.

The change was in out/azure/src/js/widgets/oxinputvalidator.js line 200:
$("." + oOptions.metodValidate + ":not(:focus)", oFieldSet).each( function(index) {