View Issue Details

IDProjectCategoryView StatusLast Update
0004211OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
ReporterSouleater 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.6.3 revision 47975 
Summary0004211: new youtube links missing in oxmediaurl.php
DescriptionThe new youtube link youtu.be for sharing is missing in oxmediaurl.php

the new code looks like this (sarting at line 135):

if (strpos($sUrl, 'youtube.com')) {
 $sYoutubeUrl = str_replace("www.youtube.com/watch?v=", "www.youtube.com/embed/", $sUrl);
 $sYoutubeUrl = preg_replace('/&/', '?', $sYoutubeUrl, 1);
 }
 if (strpos($sUrl, 'youtu.be')) {
 $sYoutubeUrl = str_replace("youtu.be", "www.youtube.com/embed/", $sUrl);
 }
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

arturas.sevcenko

2012-07-02 16:32

reporter   ~0007040

Now new youtube links are supported.