View Issue Details

IDProjectCategoryView StatusLast Update
0004175OXID eShop (all versions)3.2. HTML, CSS, JavaScriptpublic2014-02-20 11:10
Reportermarco_steinhaeuser 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version4.6.1 revision 45706 
Target Version4.9.0_5.2.0_beta1Fixed in Version 
Summary0004175: Don't use "include" in "foreach"- or "section"-loops
DescriptionIn template "out/azure/tpl/widget/product/list.tpl" is a smarty "include" inside of a foreach loop. This slows down the page, if there are many products in a category.

Solution:
Move the foreach loop to the included templates.
TagsPerformance, Smarty
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

jurate.baseviciene

2014-02-20 11:10

reporter   ~0009549

Sorry we can't reproduce such issue nor on current versions 5.0.10 neither version 5.1.3. Probably is fixed with other change. If in the future this bug will be reproduced please bug status change to "Reopen".