View Issue Details

IDProjectCategoryView StatusLast Update
0004164OXID eShop (all versions)1.11. Private Sales, Invitationspublic2012-11-23 15:24
Reporterwebformatik 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSUbuntuOS VersionPrecise
Product Version4.6.1 revision 45706 
Target VersionFixed in Version4.6.6 revision 54646 
Summary0004164: [Private Sales] Unexpected redirects to Login
DescriptionWe utilize the private sales feature of the PE. To make a few content pages accessible without prior login, we successfully extended the content class. In order to create a new view, that needs to be accessible to anyone (to embed into an iframe on a different site), I tried to extend oxcmp_user yesterday, so that my class would be accessible without having to login first. It should have worked, but I am still redirected to the login page. As a workaround i tried to realise my iframe as CMS content, as we already extended the controls that allow certain content. When rendering, the content gets assigned a fixed template, that only contains the word test(just like the test with my own view). After endless testing the following curiosity emerged:

- If private sales is active and the output of a template is too short there is a redirect to the login page. I added extra HTML-Code or 'Lorem Ipsum' paragraphs and as soon as I reach a certain amount of content it works all of a sudden.

- If private sales is active instead of the 404 error page when I try to access non existent URLs I get redirected to the login page. (Also a problem with the OXID Demoshop!) I assume this is not a seperate bug but the same problem as before since the 404 page is very light on content.
Steps To ReproduceSee description
Additional InformationZend Loader 5.5
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Version5.3
MySQL Versionany

Activities

webformatik

2012-06-25 20:55

reporter   ~0006979

Any updates?

aurimas.gladutis

2012-11-23 15:24

reporter   ~0007971

Last edited: 2012-11-23 15:24

View 3 revisions

Hi, we tried to create custom class with custom view with only one word test and it is working fine. New class have to be added to oxcmp_user::$_aAllowedClasses array and it should be fine.

As for redirecting to login page instead of 404 error page, it is expected behaviour while not logged in.

We have fixed that when user is logged in, the 404 error page would be shown instead of currently shown "my account" page.

If the problem still exists, please give us more details how to reproduce this situation.