View Issue Details

IDProjectCategoryView StatusLast Update
0004153OXID eShop (all versions)3.1. Design, GUI, UXpublic2012-08-28 10:24
Reporterleofonic 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.1 revision 45706 
Target Version4.6.3 revision 47975Fixed in Version4.5.12 revision 52682 
Summary0004153: Variant Selection fails if reviews are disabled
DescriptionIf Reviews are disabled in performance tab, selection of (md)variants is not possible.
Additional InformationSolution: details/ajax/productmain.tpl and details/ajax/fullproductinfo.tpl

change:
[{oxscript add="$( '#reviewRating' ).oxRating({openReviewForm: false, hideReviewButton: false});"}]
[{oxscript add="$( '#writeNewReview' ).oxReview();"}]

to:
[{if $oView->isReviewActive() }]
    [{oxscript add="$( '#reviewRating' ).oxRating({openReviewForm: false, hideReviewButton: false});"}]
    [{oxscript add="$( '#writeNewReview' ).oxReview();"}]
[{/if}]
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

has duplicate 0004197 closedjurate.baseviciene Deactivating "user Reviews and Ratings" cause a JavaScript error and avoid interaction on detail pages. 
has duplicate 0004248 closedsvetlana Product multi-dimensional variants do not work if rating is deactivated 
has duplicate 0004253 closedsvetlana JavaScript TypeError with multi-dimensional article variants 

Activities

ray

2012-06-26 11:34

reporter   ~0006985

here is a duplicate: https://bugs.oxid-esales.com/view.php?id=4197

arturas.sevcenko

2012-07-27 13:56

reporter   ~0007132

@leofonic this is true, solution is nice.
For quick fix everyone can use provided solution by leofonic.
This won't be fixed in any 4.6.x patches, because it is frontend template change.

arturas.sevcenko

2012-07-31 15:24

reporter   ~0007164

Last edited: 2012-07-31 15:25

View 2 revisions

Fixed for next major version

dainius.bigelis

2012-08-28 10:24

reporter   ~0007395

Fix is implemented in Patch for 4.5 (upcomming 4.5.12), also Patch for 4.6 (4.6.4), as well as in eShop 4.7.0/5.0.0.
The fix contains small template changes.