View Issue Details

IDProjectCategoryView StatusLast Update
0004140OXID eShop (all versions)2. ----- eShop backend (admin) -----public2012-06-27 11:47
ReporterFibreFoX 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.1 revision 45706 
Target VersionFixed in Version4.6.3 revision 47975 
Summary0004140: Generating a PDF ends in wrong filename
DescriptionIssue is in admin/order_overview.php

if "oxorder__oxbilllname" contains spaces or other "not allowed" characters, the downloaded file ends in some bad filename.
Steps To ReproduceHaving an order with billname like "Dr. Max Mustermann"
Go to admin-area
navigate to the order

click on pdf-export
Additional InformationUsed Firefox 13.

My current workaround:

                $billname = $oOrder->oxorder__oxbilllname->getRawValue();
                $cleaned_billname = str_replace(" ","_", $billname);
                $cleaned_billname = str_replace(".","_", $cleaned_billname);
                $cleaned_billname = str_replace(","," ", $cleaned_billname);
                $sFilename = $oOrder->oxorder__oxordernr->value . "_" . $cleaned_billname . ".pdf";
                $sFilename = str_replace(" ","_", $sFilename);
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

FibreFoX

2012-06-08 13:40

reporter   ~0006818

Last edited: 2012-06-08 13:41

View 2 revisions

i dont know, but maybe it would also be a good idea to remove \n and \t (and other special chars), because with \n there can be written other http-header information etc.

does a special sanitize-function already exist?!

arturas.sevcenko

2012-06-27 11:46

reporter   ~0006998

Now pdf generates with full name.(in firefox was an issue).