View Issue Details

IDProjectCategoryView StatusLast Update
0004082OXID eShop (all versions)1.04. Content, static (register, contact etc.) pagespublic2013-04-09 17:37
Reporterray 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.6.0 revision 44406 
Target VersionFixed in Version 
Summary0004082: CMS - content not changed when containig picture path with Smarty
DescriptionWhen clicking on a CMS-page in infobox.tpl the page is loaded. When clicking on second link, the URL and Header is refreshed, but the content does not refresh, showing still previous page.

This behaviour only occurs when the CMS-pages contain a picture which links to another CMS-page. And if this picture is included by using Smarty. If you specify the path to the picture via hardlink or with relative path, no error occurs.

not working:
<a href="[{ oxgetseourl ident="cms-ident" type="oxcontent" }]"><img src="[{$oViewConf->getImageUrl()}]bild.png" alt="" /></a>

working:
<a href="[{ oxgetseourl ident="cms-ident" type="oxcontent" }]"><img src="out/basic/img/bild.png" alt="" /></a>
Steps To Reproducedebugxxx.metallbauversand.de

Click on "Fehler A" in the infobox - it will show the content of "Fehler B". But URL and Header are correct.
Click on "Fehler B" in the infobox - Header and URL in Browser will change, still showing content of "Fehler B".
Click on "Fehler A" again, Header, URL and Title will change back, but content remains the same.
Additional InformationIt seems to be a problem with /tmp-files, as this error does not occur when freshly deleted all files in /tmp folder or when you activate "Automatic detection of necessary Template re-compilation." in core-settings.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0004298 resolvedsaulius.stasiukaitis Sometimes wrong content loaded on CMS page 

Activities

Firefax

2012-07-31 15:33

reporter   ~0007165

Hi,
the priority and servity should be increased for this bug! Wrong shown CMS-pages can cause problems from the legal point.

All CMS-pages with the smarty Tag getImageUrl seems to be affected.

cya

ray

2012-08-08 14:47

reporter   ~0007269

I second that - please increase priority, as it can cause serious legal problems for shop owners.

leofonic

2012-08-13 16:07

reporter   ~0007298

Solution here: https://bugs.oxid-esales.com/view.php?id=4298