View Issue Details

IDProjectCategoryView StatusLast Update
0004081OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
ReporterWBL_BjoernLange 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.5.12 revision 52682 
Summary0004081: "Wrong" module processing for oxbasket and oxbasketitem
DescriptionI think this is the same error of 0002620. But i can not open this ticket again. I get an fatal error to. You closed this ticket and forgot one important thing in your closing comment, the module of oxbasketitem.

You create 2 Modules, something like:
oxbasketitem => test/test_basket_item
oxbasket => test/test_basket

And oxfunctions/oxautoload::

if ( stripos( $sModuleName, $sClass ) !== false ) {
                    $myUtilsObject->getClassName( $sParentName );
                    break;
                }


will load the chain for oxbasketitem, for including test_basket
_parent while unserializing the basket object, because ( stripos('test/test_basket_item', 'test/test_basket') !== false ) is true.

Changing the sorting order of the modules did not work for me, OXID adds my module to the aDisabledModules-Array automatically. That was the point i stopped the debugging.
oxNew('oxbasket') in oxSession::getBasket() prior the unserializing solved the fatal errors for me.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

dainius.bigelis

2012-05-28 14:43

reporter   ~0006691

Reminder sent to: WBL_BjoernLange

hi,

Could you please tell on which eShop version you get this issue? We tried to reproduce that on eShop 4.6.0 but without success.

dainius.bigelis

2012-06-05 17:29

reporter   ~0006786

Reminder sent to: WBL_BjoernLange

Hi,

The same as on bug 0002620 - we cannot reproduce this issue.
We would like to get any more details about the case - on which eshop version you got this? Maybe you can attach the module files, with which you get those errors?

Best regards,

WBL_BjoernLange

2012-06-06 08:57

reporter  

basket.rar (5,146 bytes)

WBL_BjoernLange

2012-06-06 08:58

reporter   ~0006788

Last edited: 2012-06-06 08:59

View 2 revisions

Please try the attached module. The shop stops working correctly, for example, on my fresh 4.6.1 the frontend basket stays empty all the time (windows xampp php 5.3). This is not my exact module situation ;) but i can reproduce ill effects since older version and in oxid 4.6.1 too.

edvardas_gineika

2012-06-21 12:19

reporter   ~0006946

replaced stripos() with preg_match() in oxfunctions->oxautoload function