View Issue Details

IDProjectCategoryView StatusLast Update
0004034OXID eShop (all versions)1.06. Search, Tagspublic2012-12-21 13:08
Reporterloki_ 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.0 revision 44406 
Target Version4.6.6 revision 54646Fixed in Version4.6.6 revision 54646 
Summary0004034: SEO URLs Tags
DescriptionNot all tags on page tags or in the box tag cloud have SEO URLs. For some tags there is no entry in table "oxseo". So some tags will be rewritten and some not. When you click on a tag with no SEO URL the result page is empty.
Steps To Reproducehttp://demoshop.oxid-esales.com/community-edition/stichworte/
Here the tag "used" has no SEO URL. When you click on it nothing is found.
TagsSEO, Tags
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

loki_

2012-05-12 15:01

reporter   ~0006585

The problem seems to occur especially, when you enter new tags in the admin area. I can not tell on what this behaviour depends. Some long tags consisting of several words will get a SEO URL and other with only one or more word will not be rewritten.

leofonic

2012-05-14 15:04

reporter   ~0006595

"used" is a reseved word in the default stoplist.

loki_

2012-05-14 16:00

reporter   ~0006596

Hello, some examples were it does not work too:
uni cat warlock gr.90, uni cat destroyer xt-9000, uni ca tournament surface diver 60mm 10g gp, tournament surface diver 60mm 10g ft, cora-z "classic" silber/gold 45, abu garcia tormentor 70 floating h-skb, etc.

loki_

2012-05-14 16:01

reporter   ~0006597

and "shimano stradic gtm 2500 rc" gets a SEO URL "/tag/shimano-stradic-gtm-2500-rc/"!?

dainius.bigelis

2012-06-05 10:43

reporter   ~0006764

I reproduced the bug only on eShop 4.6.0 CE edition, by inserting the tag "shimano stradic gtm 2500 rc" to the product. Then it was not displayed at all in the TAGs page.
But it works properly with the tag "uni cat warlock gr.90" - it's converted to "uni cat warlock gr 90" and properly displayed in the TAGs page, with proper working SEO link.
on EE edition both tags works properly.
@Developers: please investigate this case, why on CE edition sometimes tag is not displayed in TAGs page at all.

aurimas.gladutis

2012-12-21 13:08

reporter   ~0008198

Hi, this behaviour is due to usage of full text search on tags. Mysql uses stopwords list on which it does not search. Stopwords list can be found here:
http://dev.mysql.com/doc/refman/5.1/en/fulltext-stopwords.html

Stop words can be disabled by changing mysql config file constant to:
ft_stopword_file=''

As for seo links, we are now generating seo links to all tags, but if it is in stopwords list, it will show empty list of articles, not error page though.

This stopwords list is generated by mysql and can be altered only from server side where mysql is.

Also caching not reseting when tag is entered in PE and CE editions (mentioned by dainius) is fixed.