View Issue Details

IDProjectCategoryView StatusLast Update
0004023OXID eShop (all versions)1. ----- eShop frontend -----public2014-11-11 10:00
Reportertomas_liubinas 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0004023: On high load scenario shop is shown as unlicensed
DescriptionIn high load scenario shop would go offline when there are more connections that it could serve. Similar happens when there are high load on db, the db would not be available and the shop goes offline as well. This is correct behaviour - at least it show the appropriate msg "shop offline" or smth like this. But in some cases it could happen that we have established connection to db, but we get no data for quiries back. In this case it throws a lot of errors AND shows unlicensed shop error.

Should be:
Offline error should be shown in this case.
Steps To ReproduceClean oxconfig table and try to run the shop.
TagsNo tags attached.
ThemeAll
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0005582 resolvedmantas.vaitkunas There is no check for errors in database queries when production mode turned on. This leads to unpredictable Shop state. 

Activities

rimvydas_paskevicius

2012-05-21 17:37

reporter   ~0006662

Added additional checking in oxconfig if config values were loaded on init

martinwegele

2014-10-02 10:57

reporter   ~0010207

Additional fix in 5.1.5 improved the error handling and user experience: http://wiki.oxidforge.org/Downloads/4.8.6_5.1.6#General_hints_for_this_package