View Issue Details

IDProjectCategoryView StatusLast Update
0003974OXID eShop (all versions)2.5. Administer userspublic2012-12-10 13:15
Reporterabc 
PriorityhighSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.5.12 revision 52682 
Summary0003974: Voucherseries not visible in Admin-Backend for Admin-Users.
DescriptionThe main shop-admin can edit all voucherseries normally. Another admin-user is member of the role "Vouchers (Gutscheine)". This role has been given full access to the "Shop Settings > Coupon series".
However, when this user logs in and goes to "Shop Settings > Coupon series", he only sees the voucher list in the upper half of the window, while the lower pane remains empty: only the Tab-Headlines Main, User-Groups, Mall are visible but nothing else (see screenshot).
When the user clicks on any item in the voucher list, nothing happens, i.e. no voucherseries is loaded or shown in the details pane.
It seems like the JavaScript function loadEditFrame(sUrl) is not called in this case. Since it works for the main admin, the template should be alright. It may be caused by the roles/rights settings.
Steps To ReproduceAs main admin:
1. Create a new user with Rights "Admin".
2. Go to admin-roles, create a new role and deny everything for this role, except "Shop Settings > Coupon series".
3. Assign the user created in step 1 to the role from step 2.
4. Log the main admin out of the backend.
5. Login to the admin-area as the new user from step 1.
6. Go to Shop Settings > Coupon series.
=> You see the vouchers in the list (if any exist) but nothing in the edit-panel below. When you click on a voucher, nothing changes.
Additional InformationTested with EE 4.4.2.
I have also replaced the admin-templates with the original files, but the problem still occurs.
TagsRights & Roles
ThemeBasic
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

has duplicate 0003701 closed Right&Roles not restrictable for vouchers 

Activities

abc

2012-05-02 13:58

reporter  

abc

2012-05-02 15:39

reporter   ~0006498

I have just reproduced the error under a complete fresh installation of EE 4.4.2

When loading the voucherseries page, the GET

/admin/index.php?stoken=75BBF934&&cl=voucherserie_main&oxid=-1

gets the answer "302 Found" and is redirected to

/index.php?cl=content&tpl=err_accessdenied.tpl&redirected=1

"Access denied" seems to confirm that somehow the rights/roles are not processed properly.

svetlana

2012-05-18 08:20

reporter  

2012-05-18_0919.png (99,848 bytes)
2012-05-18_0919.png (99,848 bytes)