View Issue Details

IDProjectCategoryView StatusLast Update
0003942OXID eShop (all versions)1.03. Basket, checkout processpublic2012-12-10 13:22
Reportermolineus 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.6 revision 40808 
Target VersionFixed in Version4.6.6 revision 54646 
Summary0003942: Email notifying for low stock articles does not work for variants
DescriptionIn a shop we have only parent articles with variants. There is the option set to remind the admin if the stock is low. It works for main products but does not work for variants.

We discovered that the selectString() in oxArticleList::loadStockRemindProducts does not get any articles if they are variants.
TagsOrder
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

updown

2012-05-10 19:56

reporter   ~0006560

Last edited: 2012-05-10 20:45

View 2 revisions

can confirm this - please fix this officially

(Version CE 4.5.9)

ray

2012-05-10 23:17

reporter   ~0006562

how could you fix that un-officially?

updown

2012-05-11 13:49

reporter   ~0006573

Last edited: 2012-05-11 14:16

View 2 revisions

The obvious problem is, that 'oxremindactive' is not set for variants in the oxarticles table. This value is intended to be "inherited" from parent, and therefore not set in the database for a variant. So the select-query cannot return any value different than '0'.

So a quick'n'dirty solution is to manually set 'oxremindactive' to 1 for all variants (as I did as an SQL-hack), or patch this officially:

Either
1.) make the select-query more complex to look for parent-setting if article has a parentid. Also update-query, of course.

or

2.) Rethink parent-inheritage concerning Reminders completely and make this setting individual for each variant. (like the OXREMINDAMOUNT setting already is - would be my preferred solution if anyone'd ask me ;-))

or

3.) Update every Variant-Setting when parent-setting is updated in the database. (a little bit crappy solution ;-))

aurimas.gladutis

2012-12-03 09:37

reporter   ~0008036

Hi, we have added updating of variant article to remindactive of parent item on admin/stock save. Now if you would like to have functionality in updown 2) suggestion, just remove editval[oxarticles__oxremindactive] input disabled tag in article_stock.tpl and it should be fine.