View Issue Details

IDProjectCategoryView StatusLast Update
0003935OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
Reporterray 
PriorityurgentSeveritycriticalReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version4.5.10 revision 44222 
Target VersionFixed in Version4.5.11 revision 46050 
Summary0003935: php_flag display_errors "0" in .htaccess blocks image processing / upload
Descriptionin certain enviroments (for example @Profihost) this .htaccess in /core - included since 4.5.10 - blocks image processing

from Server error-log:
/www.shop-domain.tld/core/.htaccess: Invalid command 'php_flag', perhaps misspelled or defined by a module not included in the server configuration

see thread in forums:
http://www.oxid-esales.com/forum/showthread.php?t=14223
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

ray

2012-04-26 10:36

reporter   ~0006460

Maybe this is the explanation? And possible solution as well included.

http://forums.glowhost.com/knowledge-base/error-php_flag-php_value-errors-how-fix-them-721.html

updown

2012-04-26 11:08

reporter   ~0006462

The solution with a php.ini file only works for server-administrators, and they don't need such an error-directive at all.

Delete the htaccess-file, and if path-disclosures can appear, fix them in the files directly.

dainius.bigelis

2012-05-08 02:04

reporter   ~0006529

.htaccess files removed from /core and /views directories.