View Issue Details

IDProjectCategoryView StatusLast Update
0000039OXID eShop (all versions)4. ------ eShop Core -------public2012-12-10 13:42
Reporterdainius.bigelis 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Product Version 
Target VersionFixed in Version 
Summary0000039: User should not be logged out from system automatically (because session doesn't expires)
DescriptionAfter certain time user is loged out automatically (from admin and frontend).
System should not logout user because session expiration is already removed together with moving sessions to cookies.

Other question - are the options in admin for defining expiration time for admin and frontend still needed or not (i.e. if shop owner selects to not use cookies for session handling) ?
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Activities

sarunas_valaskevicius

2008-09-11 13:39

reporter   ~0000069

Last edited: 2008-09-11 13:39

possible reason for this is php session.gc_maxlifetime setting, which defines after how many seconds of idle time session will be cleaned. [still need to check it]

sarunas_valaskevicius

2008-09-18 13:05

reporter   ~0000091

php session.gc_maxlifetime setting is affecting this (php.ini file), change it to big enough value for session to be alive longer