View Issue Details

IDProjectCategoryView StatusLast Update
0003875OXID eShop (all versions)4.02. Session handlingpublic2012-04-19 09:48
ReporterGhostGambler 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.9 revision 43186 
Target VersionFixed in Version4.5.10 revision 44222 
Summary0003875: Session gets lost when using ADODB
DescriptionADODB_Session::sess_read
expects the fetchMode ADODB_FETCH_NUM, but in some cases the fetchMode is set to ADODB_FETCH_ASSOC before. In that case there will be read an empty part of the array in line 78 ($result->fields[0]; -- because the session data is in session_data and not in 0) and therefore the session will be closed.

A backtrace in line 63 gives the following output in case of the wrong fetchMode
Backtrace #0 ADODB_Session::sess_read(38e927b82b5dfe6cd481c5740f7b2c62)
#1 session_start() called at [/var/www/Programm/core/oxsession.php:358]
#2 oxSession->_sessionStart() called at
[/var/www/Programm/core/oxsession.php:268]
#3 oxSession->start() called at [/var/www/Programm/core/oxconfig.php:447]
#4 oxConfig->init() called at [/var/www/Programm/core/oxconfig.php:495]
#5 oxConfig::getInstance() called at [/var/www/Programm/index.php:78]
#6 require(/var/www/Programm/index.php) called at
[/var/www/Programm/oxseo.php:46]
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0000853 resolvedLinas Kukulskis DB Session handling in eShop 4th does not work at all 

Activities

Linas Kukulskis

2012-04-19 09:48

reporter   ~0006335

forced assoc fetch mode in adodb class