View Issue Details

IDProjectCategoryView StatusLast Update
0003771OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2015-05-04 14:15
Reporter[email protected] 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.4 revision 39463 
Target VersionFixed in Version4.5.10 revision 44222 
Summary0003771: if u set the coupons valid date from but don't set until date it will let u use coupons no matter what date from was setted
Descriptionbug in oxvoucher::_isValidDate
if ( ( strtotime( $oSerie->oxvoucherseries__oxbegindate->value ) < time() &&
              strtotime( $oSerie->oxvoucherseries__oxenddate->value ) > time() ) ||
            !$oSerie->oxvoucherseries__oxenddate->value ||
            $oSerie->oxvoucherseries__oxenddate->value == $sDefTimeStamp ) {
            return true;
        }

This if return true if begindate set to tomorows date and enddate is set to 0, so it will let u use the coupons, if you set the enddate to next month it will work corretly as i see where is a bug in if. unles it intended to be so.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

saulius.stasiukaitis

2012-04-20 07:46

reporter   ~0006360

Function _isValidDate rewritten.