View Issue Details

IDProjectCategoryView StatusLast Update
0003717OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
Reporterleofonic 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.0_beta2 
Target VersionFixed in Version4.6.0_RC2 
Summary0003717: oxemailfailed set for valid addresses
DescriptionIn core/oxnewsletter.php, if PHPmailer returns false on send, oxemailfailed is updated and set to "1" in the customers data. This is more likely due to own setup, like own SMTP not reachable or wrong credentials, so i think customer data should not be updated automatically.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Activities

vaidas.matulevicius

2012-04-19 10:07

reporter   ~0006337

In oxnewsletter send function removed database 'oxnewssubscribed' field 'oxemailfailed' setting to 1, if email sending fails.