View Issue Details

IDProjectCategoryView StatusLast Update
0003685OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
Reportertjungcl 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.5.8 revision 42471 
Target VersionFixed in Version 
Summary0003685: oxutilsfile still cant be overloaded
Descriptionhad be reported 2009 for version 4.1.3.
If I'm not overseeing something, its still not possible to overload some classes, that dont seem so complicated.

oxutilsfile is one of them, i didnt try all others.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0001097 resolvedtomas_liubinas Some Classes cant be overloaded 

Activities

tjungcl

2012-03-07 14:39

reporter   ~0005908

old report was:
https://bugs.oxid-esales.com/view.php?id=1097

Adrian.Kirchner

2012-03-08 21:59

reporter   ~0005919

+1
same problem here.
in this case it should be enough to use oxNew() in the oxUtilsFile::getInstance()-Method. No need of a "small concept" ;)

tjungcl

2012-03-19 10:23

reporter   ~0006032

related to https://bugs.oxid-esales.com/view.php?id=3729
(i need to extend oxutilsfile for the same reason)

leofonic

2012-03-19 12:47

reporter   ~0006033

I think oxutilsfile can be overloaded if this is added to config.inc.php:
    //Load Modules
    include getShopBasePath().'core/oxconfk.php';
    $this->_loadVarsFromDb( $this->getShopId(), array('aModules') );

jurate.baseviciene

2012-04-27 13:19

reporter   ~0006473

We closed this bug because is reopen the bug (https://bugs.oxid-esales.com/view.php?id=1097, and we'll fix it