View Issue Details

IDProjectCategoryView StatusLast Update
0003610OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2014-09-24 13:36
Reporterray 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.7 revision 41909 
Target VersionFixed in Version6.0.0-beta.1 
Summary0003610: attributes of father are not inherited if variants are compared
DescriptionIf you compare variants of an article, only direct attributes of the variants are taken. All (unchanged) attributes of the father items are not displayed.
Steps To Reproducecompare different variants with several inherited and some own attributes
Additional Informationcheck here, including screenshots:
http://www.oxid-esales.com/forum/showthread.php?p=82114#top

First screen normal behaviour in the shop, second screen after some modifications. It should work like in second screen.
TagsAttributes
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005135 resolvedjurate.baseviciene newly added attributes will not be shown in checkout 

Activities

Linas Kukulskis

2012-04-20 14:02

reporter   ~0006374

in attributes included parent attributes

dainius.bigelis

2012-04-25 15:17

reporter   ~0006449

Issue reopened and will be investigated in more details, to be sure that not harms the shops.

ray

2012-04-25 17:39

reporter   ~0006455

you can check here how it was solved via module by an user in forums:
http://www.oxid-esales.com/forum/showthread.php?t=13374#post82372

leofonic

2012-06-24 15:37

reporter   ~0006965

There is a fix here: 0003918, and according to the last comment there it should already be present in 4.6.1, but it isn't.

Linas Kukulskis

2012-11-21 14:36

reporter   ~0007932

added fix

ray

2013-05-15 11:14

reporter   ~0008702

Last edited: 2013-05-15 11:17

View 2 revisions

seems to be not (completely) fixed in actual 4.7 versions - see following comment

patchwork.de

2013-05-15 11:29

reporter   ~0008703

Last edited: 2013-05-15 11:33

View 2 revisions

the issue as discribed is NOT fixed in 4.7.1 - 4.7.5 !
if variants are put in basket no attributes of father article are shown - only attributes of variant.
Can be fixed easily by adding the parent-attributeslist in basket

Linas Kukulskis

2013-05-20 16:08

reporter   ~0008706

Do you mean getAttributesDisplayableInBasket() method do not deliver parent attributes?

patchwork.de

2013-06-02 15:00

reporter   ~0008734

dont know this method - but has been solved by user with module - see above note 0006455

Linas Kukulskis

2014-09-24 13:36

reporter   ~0010180

fixed attributte selection and view