View Issue Details

IDProjectCategoryView StatusLast Update
0003516OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
Reporterboehme 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.5.5 revision 40299 
Target VersionFixed in Version4.5.8 revision 42471 
Summary0003516: oxarticle::getArticleLongDesc() inheritance does not work properly
Description
$sDbValue = oxDb::getDb()->getOne( "select oxlongdesc from {$sViewName} where oxid = ?", array( $sOxid ) );
if ( $sDbValue !== false ) {
// use it!
} elseif ( $this->oxarticles__oxparentid->value ) {
// load from parent
}

db: oxartextends.oxlongdesc is configured as not null, no specific default value

per default oxartextends.oxlongdesc will be an empty string. When you save an empty longdesc it will be an empty string. If getting the longdesc is checked by !== false this will never be false, so the inheritance won't take effect.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0002956 resolvedvilma_liorensaityte Article Long Description doesnt inherit from parent article to variant 

Activities

boehme

2012-01-23 14:03

reporter   ~0005625

my fault, sry.

duplicate of resolved 0002956.