View Issue Details

IDProjectCategoryView StatusLast Update
0003435OXID eShop (all versions)4.06. Language and translationspublic2012-02-10 15:15
Reportertjungcl 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.5 revision 40299 
Target VersionFixed in Version4.6.0_beta3 
Summary0003435: 'WIDGET_LOGINBOX_LOGIN' => 'Login' used in 4 completly different cases
Descriptionit is used as
- the text of the header-link, where you open the login-popup
- the title of that link
- the h4 tag of the popup
- the button to submit

So by overwriting WIDGET_LOGINBOX_LOGIN, you can only influence all those places at once, and because it is also used as the title-tag of a link, you can not use html in it, such as 'Login<img ... />' which you otherwise could.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Activities

dainius.bigelis

2011-12-28 15:05

reporter   ~0005538

@Developers: please check from the source code side if it's true as reported and if so - fix to improve these places.

Linas Kukulskis

2012-02-10 15:15

reporter   ~0005714

analyzed usage. changed to generic LOGIN constant.
Used correctly. We cant provide different constants in one template for the same label. if it is needed please use custom constants and different template (its possible override only one tpl in custom theme)