View Issue Details

IDProjectCategoryView StatusLast Update
0003423OXID eShop (all versions)1.03. Basket, checkout processpublic2012-12-07 15:17
Reporterleofonic 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.5.5 revision 40299 
Target VersionFixed in Version 
Summary0003423: Html Tags in Payment Description are shown in Frontend
DescriptionHtml Tags used in Payment Description either in Source Mode or by using design mode are shown in Frontend and emails. e.g. Paypal module uses html tags here.
Additional InformationAdditionally, the help text "Note: If you need to preserve text line breaks (e.g. plaintext e-mails), please use tab "html CODE" instead of "Design"." is misleading.
- In CE, there is no Design Tab.
- Why "in plaintext emails"? Much more interesting would be how to preserve Line Breaks in Frontend or Html Mails.

And slightly OT: Does this Text have to be shown in mails at all? e.g. in Paypal module:

"<div>When selecting this payment method you are being redirected to PayPal where you can login into your account or open a new account. In PayPal you are able to authorize the payment. As soon you have authorized the payment, you are again redirected to our shop where you can confirm your order.</div> <div style="margin-top: 5px">Only after confirming the order, transfer of money takes place.</div>"

or CC:
"Your Credit Card will be charged when you submit the order"

this does not make much sense in an email.
TagsPayment
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0003533 resolvedLinas Kukulskis Payment long description html entities are not parsed 

Activities

ray

2012-01-31 15:35

reporter   ~0005670

here is a dublicate: https://bugs.oxid-esales.com/view.php?id=3533 (and solved already)

dainius.bigelis

2012-02-07 13:53

reporter   ~0005680

Closed as duplicate of 0003533