View Issue Details

IDProjectCategoryView StatusLast Update
0003418OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
Reporterboehme 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.5 revision 40299 
Target VersionFixed in Version4.5.10 revision 44222 
Summary0003418: multiple oxViewConfig instances created if block.oxifcontent is used
DescriptionOxids smarty block oxifcontent parses smarty code of a cms snippet with oxUtilsView::parseThroughSmarty. Two parameters are passed to this method: the smarty code and the contentid, the third parameter ($oActView) is optional and not set.
With each content block being parsed a new instance of oxViewConfig will be created, because no view has been passed to the parse-method:
if ( !$oActView ) {
  $oActView = oxNew( 'oxubase' );
  $oActView->addGlobalParams();
}

Normally the oxViewConfig instance is cached in the active view.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Linas Kukulskis

2012-04-19 14:40

reporter   ~0006344

added active view parameter to function call