View Issue Details

IDProjectCategoryView StatusLast Update
0003405OXID eShop (all versions)2.3. Extensions (modules, themes)public2012-12-10 13:33
Reporterleofonic 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.5.4 revision 39463 
Target VersionFixed in Version 
Summary0003405: Switching Images in Zoom-Popup of Variants does not work if Article has no Cross-Selling
DescriptionIn productmain.tpl and fullproductinfo.tpl there is a script:
[{oxscript add="$( 'ul.js-articleBox' ).oxArticleBox();"}]
This fails if there is no 'ul.js-articleBox' on the page and causes the error when switching zoom-popup in Variants.

This script is also contained in boxproducts.tpl itself, so it is not needed in productmain.tpl and fullproductinfo.tpl.
Steps To ReproduceIn Demoshop, remove all crossselings from this article:
http://demoshop.oxid-esales.com/community-edition/Bekleidung/Fashion/Fuer-Sie/Shirts-Co/Stewart-Brown-Organic-Pima-Edged-Lengthen.html

Select a Variant and open Zoom Popup. Switching Images is not possible.
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0003400 resolvedmindaugas.rimgaila Zoom Mouseover is not displayed for variants in Google Chrome 

Activities

progress68

2011-11-30 13:43

reporter   ~0005456

It even doen´t work when the variant has crosselling or accessories

leofonic

2011-12-13 16:44

reporter   ~0005488

Duplicate of https://bugs.oxid-esales.com/view.php?id=3400

dainius.bigelis

2011-12-28 15:31

reporter   ~0005540

The issue is fixed together with bug 0003400, so this marked as duplicate.