View Issue Details

IDProjectCategoryView StatusLast Update
0003369OXID eShop (all versions)1.05. Userspublic2011-11-21 10:48
Reportertjungcl 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.4 revision 39463 
Target VersionFixed in Version4.5.5 revision 40299 
Summary0003369: in account newsletter settings: click on breadcrumb sets newsletter subscription to false
Descriptionreproducable in demoshop:

- log into an user account in frontend
- go to account settings, newsletter settings
- set newsletter to yes, save
- click on breadcrumb
=> the subscription is canceled (set to no)

The reason seems to be the fnc=subscribe in the breadcrumb link, which executes the function but and takes false as status (which is not defined).
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Arunas

2011-11-21 10:48

reporter   ~0005412

fixed in the patch 4.5.5. There's no "subscribe" function in the breadcrumb and added an additional check in the function.