View Issue Details

IDProjectCategoryView StatusLast Update
0003341OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2012-12-07 14:28
Reporterhenrik.steffen 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformallOSallOS Versionall
Product Version4.5.4 revision 39463 
Target VersionFixed in Version4.5.7 revision 41909 
Summary0003341: recommended retail price is not displayed sometimes
Description1. In some cases the recommended retail price (RRP / UVP) will not be shown.
2. The price range for error message is wrong. When user saves the price, which is smaller than oxprice, the error message is displayed "Attention: RRP price must be bigger than normal price.". But this message should be displayed also when user tries to save the RRP, which is equal to oxPrice.
Currently it allows to save such RRP price, no error message is shown (wrong), thought RRP price is not displayed in frontend (good).
Steps To ReproduceIf you set oxprice to 8,00 EUR and oxtprice to 10,00 EUR on details view the recommended retail price (RRP / UVP) will not be shown.

If you set oxtprice to 9,00 EUR instead, it will be shown.

TagsProducts
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

dainius.bigelis

2012-01-16 11:53

reporter   ~0005607

Last edited: 2012-01-16 11:57

View 2 revisions

@Developers: in latest Major version source code - there is no such issue - the described case works well and RRP price is shown when it's bigger than oxprice.
The issue is only on 4.5 maintenance branch, and it might be related to the fix:
https://bugs.oxid-esales.com/view.php?id=2874

Please check if it's possible to implement the fix for RRP price handling (at least point #1) on 4.5 maintenance branch (i.e. if it does not need template changes).

mindaugas.rimgaila

2012-01-16 15:40

reporter   ~0005608

1. Front end fix will be available in 4.6 version.
2. Admin interface fix will be available in Patch.