View Issue Details

IDProjectCategoryView StatusLast Update
0003339OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
Reporterleofonic 
PriorityhighSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version4.5.4 revision 39463 
Target VersionFixed in Version4.5.12 revision 52682 
Summary0003339: Sometimes an error is shown when pictures or elements with pictures are deleted
DescriptionOn some systems e.g. when an article is deleted, the following message appears several times:
Warning: Invalid argument supplied for foreach() in /var/www/vhosts/xxx/httpdocs/oxid/core/oxutilspic.php on line 144
Additional InformationIn other places where glob is used, an additional check for is_array was implemented in case glob returns false if nothing is found, e.g. 0001742
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

ray

2011-10-28 12:05

reporter   ~0005350

check here in forums:
http://www.oxid-esales.com/forum/showthread.php?t=10923&page=2#post71768

ray

2012-04-22 18:24

reporter   ~0006394

once again -> http://www.oxid-esales.com/forum/showthread.php?p=87570#post87570

and lots of other users report same problem on vanilla installations
http://www.oxid-esales.com/forum/showthread.php?t=13716#post84457

dainius.bigelis

2012-04-23 08:45

reporter   ~0006397

@Developers: please debug this issue from the source code side, as it occurs only sometimes, not sure on which conditions. We cannot reproduce it locally.